Trouble shooting Serial port connection for equipments using VETport Uploader

Simple steps can be followed by the Clinic/Hospital to trouble shoot the problem of why analyzer data is not being received by VETport Uploader application running on your local machine and capturing and transferring lab reports to online VETport

Primary Step

Abaxis Machine Must Never be Switched Off

If Switched Off Please Switch On the Abaxis Machine First and than Reboot The PC it is connected to

VETport Uploader >> view for Serial port capture

There are 2 applications running for capturing lab reports via serial port. Please check that both are running - i.e SIO and Caravan

You can chek / Run the Applications
1) You can start the Utility by Double Clicking on Start VETport
2) Opening TrayIT you need to see if you Find Caravan Server Running
3) You need to check if Caravan Seever Autp Uploader is Working
OR
4) You can check it on the tray if you Find the Icon with Caravan Server is Working.

Check if the serial port is recognized and the equipment is connected to the port

1. Right click on computer and select properties
2. select properties
3. Go to device manager
4. Check universal serial bus - here no serial ports are seen. Try connecting the equipment and check if the serial port is available.

Once properly Configured It Should be shown as below

1. For Abaxis Blood Analyzer it should show with the proper name as shown above.
2. For HM2/5 Machines it can show USB serial port Working as shown above.

Device driver not properly installed.

If the Device driver is not properly installed it will show the Yellow mark as in above screen shot.
You need to Uninstall the Driver and Re Install the device driver for the same.

Access VETport uploader via a browser

1. Type http://127.0.0.1:9005 or http://localhost:9005
2. Login - admin p/w: heska

Check the serial port configuration on VETport uploader application

Check whether serial port is configured and working:
1. After login, type 127.0.0.1/portman.html. Click on VETport link
2. Click on VETPORT link to configure and check the serial port configuration
3. If the port is properly initialized the date and time will show in yellow or green. Presently RED since the serial port is missing.

In case new ports are seen - then restart both Caravan and SIO

It is seen that even if the serial ports are configured for specific ports, the equipment can be replugged to some other ports or new equipments are added to new ports. In that case, please RESTART both Caravan and SIO applications. These applications will automatically recognize new serial ports and all you need to do is reconfigure the serial ports via 127.0.0.1:9005/portman.html

Comments (0)

Add your comment

E-Mail me when someone replies to this comment